Friday, January 13, 2012

My latest ubuntu 11.x "new build" apt-install-list

Just so I don't forget. Latest list of apps I install after a fresh install of Ubuntu 11.x (currently on 11.10):

## Source list
## --------------------
vi /etc/apt/sources.list

# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ dists/oneiric/main/binary-i386/

# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ oneiric main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu oneiric partner
# deb-src http://archive.canonical.com/ubuntu oneiric partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu oneiric main
deb-src http://extras.ubuntu.com/ubuntu oneiric main

#Third Parties Latest Software
deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main

#medibuntu
# sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2EBC26B60C5A2783
deb http://packages.medibuntu.org/ natty free non-free
deb-src http://packages.medibuntu.org/ natty free non-free

#google
# sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com A040830F7FAC5991
deb http://dl.google.com/linux/deb/ stable non-free main

#Canonical 'partner' Repository
deb http://archive.canonical.com/ubuntu natty partner
deb http://archive.canonical.com/ubuntu natty-backports partner
deb http://archive.canonical.com/ubuntu natty-updates partner
deb http://archive.canonical.com/ubuntu natty-security partner
deb http://archive.canonical.com/ubuntu natty-proposed partner
deb-src http://archive.canonical.com/ubuntu natty partner
deb-src http://archive.canonical.com/ubuntu natty-backports partner
deb-src http://archive.canonical.com/ubuntu natty-updates partner
deb-src http://archive.canonical.com/ubuntu natty-security partner
deb-src http://archive.canonical.com/ubuntu natty-proposed partner

# Ubuntu supported packages
deb http://archive.ubuntu.com/ubuntu/ natty main restricted multiverse universe
deb http://archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ natty-updates main restricted multiverse universe
deb http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu natty-proposed main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ natty main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ natty-updates main restricted multiverse universe
deb-src http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu natty-proposed main restricted universe multiverse



## APT installs, etc:
## --------------------
apt-key adv --recv-keys --keyserver keyserver.ubuntu.com DCF9F87B6DFBCBAE F9A2F76A9D1A0061 A040830F7FAC5991 2EBC26B60C5A2783

apt-get update && sudo apt-get dist-upgrade
apt-get install build-essential checkinstall cdbs devscripts dh-make fakeroot libxml-parser-perl check avahi-daemon

add-apt-repository ppa:ferramroberto/java && apt-get update
apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
apt-get install vlc mplayer
apt-get install -Y vlc mplayer
apt-get -Y install vlc mplayer
apt-get install vlc mplayer -Y
apt-get install vlc mplayer -y
apt-get --fix-missing
apt-get install vlc mplayer --fix-missing -y

apt-get install libxine1-ffmpeg gxine mencoder mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg libmp4v2-0 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview flac libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev -y

apt-get install libxine1-ffmpeg gxine mencoder mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg libmp4v2-0 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview flac libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev fix-missing -y

apt-get install libxine1-ffmpeg gxine mencoder mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg libmp4v2-0 totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libquicktime1 flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview flac libmpeg3-1 mpeg3-utils mpegdemux liba52-0.7.4-dev --fix-missing -y

apt-get install gstreamer0.10-ffmpeg gstreamer0.10-fluendo-mp3 gstreamer0.10-gnonlin gstreamer0.10-sdl gstreamer0.10-plugins-bad-multiverse gstreamer0.10-schroedinger gstreamer0.10-plugins-ugly-multiverse totem-gstreamer -y

apt-get install gstreamer-dbus-media-service gstreamer-tools ubuntu-restricted-extras -y
apt-get install libdvdread4 && sudo /usr/share/doc/libdvdread4/./install-css.sh
apt-get install gsfonts gsfonts-x11 flashplugin-nonfree -y
apt-get install flashplugin-installer -y
apt-get install flashplugin-nonfree -y
apt-get install flashplugin-nonfree --fix-missing -y

add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update
apt-get install wine playonlinux
apt-get install wine playonlinux --fix-missing

add-apt-repository ppa:chromium-daily/stable && apt-get update
apt-get install chromium-browser chromium-browser-l10n -y
apt-get install multiget -y
apt-get install evolution evolution-mapi -y
apt-get install thunderbird -y

add-apt-repository ppa:telepathy/ppa && sudo apt-get update
apt-get install empathy telepathy-mission-control-5 telepathy-gabble telepathy-butterfly telepathy-haze telepathy-idle telepathy-salut telepathy-sofiasip libtelepathy-farsight0 python-tpfarsight galago-eds-feed python-galago python-galago-gtk msn-pecan -y

add-apt-repository ppa:pidgin-developers/ppa && sudo apt-get update -y
apt-get install pidgin pidgin-data pidgin-lastfm pidgin-guifications msn-pecan pidgin-musictracker pidgin-plugin-pack pidgin-themes -y

add-apt-repository ppa:bjfs/ppa && sudo apt-get update
apt-get install emesene -y
apt-get install skype -y
apt-get install acroread -y

wget http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin

chmod +x ./AdobeAIRInstaller.bin

./AdobeAIRInstaller.bin

apt-get install rhythmbox -y
apt-get install banshee banshee-extension-ubuntuonemusicstore banshee-extension-appindicator banshee-extension-lyrics banshee-extension-mirage -y
apt-get install amarok amarok-common -y
apt-get install gparted ntfsprogs menu ntfs-config -y
apt-get install apt-get install ntfs-3g -y
apt-get install ntfs-3g -y
apt-get install gparted ntfsprogs menu -y
apt-get install ntfs-config -y
apt-get install inkscape -y
add-apt-repository ppa:matthaeus123/mrw-gimp-svn && sudo apt-get update
apt-get install gimp gimp-data gimp-plugin-registry gimp-data-extras -y
apt-get install pinta -y
apt-get install blender -y
apt-get install gedit gedit-plugins gedit-developer-plugins -y
add-apt-repository ppa:libreoffice/ppa && sudo apt-get update
apt-get install libreoffice libreoffice-pdfimport libreoffice-math libreoffice-wiki-publisher libreoffice-report-builder libreoffice-gnome -y
apt-get install dia -y

wget http://nchc.dl.sourceforge.net/sourceforge/openproj/openproj_1.4-2.deb && sudo dpkg -i
dpkg -i openproj_1.4-2.deb

apt-get install quanta kompozer netbeans rabbitvcs-cli rabbitvcs-gedit rabbitvcs-nautilus
killall nautilus
apt-get install filezilla filezilla-common -y
apt-get install deluge-torrent
apt-get install deluge-torrent --fix-missing -y
apt-get install azureus -y
apt-get install amule -y
apt-get install k3b k3b-data libk3b6 -y
apt-get install brasero -y

wget http://dl.google.com/linux/deb/pool/non-free/g/google-desktop-linux/google-desktop-linux_current_amd64.deb && sudo dpkg -i google-desktop-linux_current_amd64.deb

wget http://dl.google.com/linux/deb/pool/non-free/p/picasa/picasa_3.0-current_amd64.deb && sudo dpkg -i picasa_3.0-current_amd64.deb

apt-get install googleearth-package -y
apt-get install checkgmail -y
apt-get install checkgmail --fix-missing
apt-get install gufw -y
apt-get install gnome-do -y
add-apt-repository ppa:ubuntu-tweak-testing/ppa && sudo apt-get update
apt-get install ubuntu-tweak -y
wget http://hacktolive.org/files/app_runner/App_Runner_0.4.9.deb && dpkg -i App_Runner_0.4.9.deb

##### The following is in addition (currently added onLinux MINT KDE 12):
apt-get install clusterssh
apt-get install konversation
apt-get install aircrack-ng -y
apt-get install irssi -y
apt-get install kvirc -y
apt-get install seamonkey-chatzilla -y
apt-get install bitlbee -y
apt-get install smuxi -y
apt-get install smuxi-engine-irc -y
apt-get install smuxi-frontend-gnome-irc -y
apt-get install smuxi-frontend-kde-irc -y
apt-get install alice -y
apt-get install lirc -y
apt-get install banshee-extension-lirc -y
apt-get install bip -y
apt-get install blootbot -y
apt-get install bobot++ -y
apt-get install cgiirc -y
apt-get install cwirc -y
apt-get install dircproxy -y
apt-get install eggdrop -y
apt-get install ekg2 -y
apt-get install ekg2-gnupg -y
apt-get install ekg2-jabber -y
apt-get install ekg2-remote -y
apt-get install ekg2-scripting-perl -y
apt-get install ekg2-scripting-python -y
apt-get install ekg2-scripting-gtk -y
apt-get install ekg2-ui-gtk -y
apt-get install ekg2-ui-ncurses -y
apt-get install ekg2-xosd -y
apt-get autoremove
apt-get install epic5 -y
apt-get install fgfs-aircraft-base -y
apt-get install gozerbot -y
apt-get install gozerbot-plugins -y
apt-get install ibid -y
apt-get install ii -y
apt-get install ircii -y
apt-get install ircmarkers -y
apt-get install iroffer -y
apt-get install jabber-irc -y
apt-get install jirc -y
apt-get install jsonbot -y
apt-get install kgb-bot -y
apt-get install kgb-client -y
apt-get install kgb-client-git -y
apt-get install openssh-server -y
apt-get install kvirc-data -y
apt-get install libanyevent-irc-perl -y
apt-get install libbot-basicbot-perl -y
apt-get install libfile-dircompare-perl -y
apt-get install libirc-formatting-html-perl -y
apt-get install libirc-utils-perl -y
apt-get install libircclient1 -y
apt-get install libirclib-java -y
apt-get install libirclib-java-doc -y
apt-get install libnet-irc-perl -y
apt-get install libnet-irc-ruby -y
apt-get install loqui -y
apt-get install manderlbot -y
apt-get install minbif -y
apt-get install minbif-webcam -y
apt-get install nadoka -y
apt-get install nagircbot -y
apt-get install phenny -y
apt-get install php-net-smartirc -y
apt-get install piespy -y
apt-get install pisg -y
apt-get install plum -y
apt-get install pork -y
apt-get install python-irclib -y
apt-get install quassel-client -y
apt-get install quassel-client-qt4 -y
apt-get install rbot -y
apt-get install rbot-doc -y
apt-get install sbnc -y
apt-get install sbnc-mysql -y
apt-get install sbnc-php -y
apt-get install sbnc-php-dev -y
apt-get install sbnc-tcl -y
apt-get install scrollz -y
apt-get install searchandrescue -y
apt-get install sic -y
apt-get install sirc -y
apt-get install sugar-irc-activity -y
apt-get install supybot -y
apt-get install sushi-plugins -y
apt-get install talksoup.app -y
apt-get install tekka -y

apt-get install tinyirc -y
apt-get install tircd -y
apt-get install weechat -y
apt-get install weechat-scriptd -y
apt-get install weechat-scripts -y
apt-get install xchat-kde -y
apt-get install xchat -y
apt-get install znc -y
apt-get install znc-perl -y
apt-get install znc-python -y
apt-get install znc-tcl -y
apt-get install znc-ruby -y
apt-get install minbif-webcam -y
apt-get install lostirc -y
apt-get install xchat-gnome -y
apt-get install p0f -y
apt-get install thinkfinger-tools -y
apt-get install keepassx -y
apt-get install p7zip -y
apt-get install htop -y
apt-get install devede -y
apt-get install conky-all -y
apt-get install furiusisomount -y
apt-get install artha -y
apt-get install deja-dup -y
apt-get install luckybackup -y
apt-get install powertop -y
apt-get install ntop -y
apt-get install gtkhash -y
apt-get install lsof -y
apt-get install tcpdump -y
apt-get install blueproximity -y
apt-get install gnome-rdp -y
apt-get install kde-rdp -y
apt-get install krename -y
apt-get install sysinfo -y
apt-get install lshw-gtk -y
apt-get install gprename -y
apt-get install dvdbackup -y
apt-get install sshfs -y
apt-get install hddtemp -y
apt-get install hplip-gui -y
apt-get install hplip -y
apt-get install hot-babe -y
apt-get install encfs -y
apt-get install screenie-qt -y
apt-get install urar-free -y
apt-get install unrar-free -y
apt-get install fdupes -y
apt-get install aptlinex -y
apt-get install rdiff-backup -y
apt-get install xsysinfo -y
apt-get install quicktime-utils -y
apt-get install quicktime-x11utils -y
apt-get install tleds -y
apt-get install warzone2100 -y
apt-get install widelands -y
apt-get install glest -y
apt-get install glob2 -y
apt-get install lightyears -y
apt-get install boswars -y
apt-get install nexuiz -y
apt-get install sauerbraten -y
apt-get install alien-arrena -y
apt-get install alien-arena -y

apt-get install assaultcube -y
apt-get install warsow -y
apt-get install rott -y
apt-get install wesnoth -y
apt-get install freeciv -y
apt-get install freeciv-client -y
apt-get install freeciv-client-gtk -y
apt-get install freecol -y
apt-get install konquest -y
apt-get install lordsawar -y
apt-get install flightgear -y
apt-get install antigravitaattori -y
apt-get install lincity -y
apt-get install dreamchess -y
apt-get install k3d -y
apt-get install sunflow -y
apt-get install structure-synth -y
apt-get install gthumb -y

apt-get install shotwell phatch gpicview qtpfsgui eog postr gpixpod photoprint gqview gtkam kflickr luciole qiv gliv kphotoalbum -y
apt-get install fotowall gnome-specimen -y
apt-get install xsane gscan2pdf scantailor flegita skanlite -y
apt-get install calibre gthumb evince geeqie comix mirage fbreader kchmviewer gpicview xchm gtpfsgui feh flpsed cbrpager qcomicbook aqsis epdfview gtkam nfoview xpdf-reader aeskulap apvlv buxon camorama djview4 fslview gvomaque yorick-cubeview pdfedit txtreader -y

### Here you see that I start getting really lazy, rofl. I put in a loop, to catch errors with installs.

apt-get install calibre gthumb evince geeqie comix mirage fbreader kchmviewer gpicview xchm qtpfsgui feh flpsed cbrpager qcomicbook aqsis epdfview gtkam nfoview xpdf-reader aeskulap apvlv buxon camorama djview4 fslview gv
omaque yorick-cubeview pdfedit txtreader

for i in calibre gthumb evince geeqie comix mirage fbreader kchmviewer gpicview xchm qtpfsgui feh flpsed cbrpag
er qcomicbook aqsis epdfview gtkam nfoview xpdf-reader aeskulap apvlv buxon camorama djview4 fslview gv omaque
yorick-cubeview pdfedit txtreader; do apt-get install $i -y; done

for i in openoffice.org lyx leafpad scite diffuse kwrite bless cssed hexedit bvi dhex entagged lfhex ncurses-he
xedit vim-athena vim-dc vim-gtk vim-rals vim-scripts vim-syntax-gtk ; do apt-get install $i -y; done

for i in mintmenu docky wine1.2 terminator alien system-config-samba pysdm cryptkeeper openbox compizconfig-set
tings-manager firestarter nvidia-settings mintdesktop screen boochart bum sbackup apturl nautilus-gksu fslint m
int-artwork-gnome virt-manager lvm2 prelink grub2-splashimages pybootchartgui crack-md5 dmraid foremost mdadm m
emlockd puppet safecopy sysv-rc-conf add-apt-key atop bluewho chkconfig crack dselect ipstate pwgen recover zer
ofree seroinstall-injector aide aide-dynamic aide-xen apachetop apg apt-btrfs-snapshot apt-file apt-dater apt-d
ater-host apt-forktracer apt-move apt-offline apt-offline-gui apt-show-source apt-show-versions apt-src apt-tra
nsport-debtorrent apt-watch-backend apt-zip apticron aptitude-doc-en aptitude-gtk aptsh arp-scan arpwatch array
-info arrayprobe asql auto-apt automysqlbackup autospy backup-manager backup-manager-doc backup2l backupninja b
acula bacula-client bacula-common-mysql bacula-console bacula-director-common bacula-sd bacula-sd-mysql bacula-
server bacula-traymonitor balance battery-stats bindgraph bld blktool bootmail btrfs-tools bup cdbackup cedar-b
ackup ceph ceph-client-tools ceph-fuse cfengine3 cfget cfgstoragemaker check-mk-agent check-mk-agent-logwatch c
heck-mk-agent-icinga check-mk-agent-nagios3 check-mk-livestatus check-mk-multisite check-mk-server checksecurit
y checkservice chntpw chrony chrootid cloud-init cloud-initramfs-growroot cloud-initramfs-rescuevol cloud-utils
cman console-log conspy convirt cpureqd cpuid cpulimit crack-common cracklib-runtime createrepo cron-apt cronu
tils cruft cryptmount daemontools daptup dchroot dchroot-dsa dconf ddpt desktop-profiles detachtty ; do apt-get
install $i -y; done

2 comments:

Anonymous said...

You should just run Windows will all that stuff! LOL j/k - Simone

Wrex's World said...

Shut yer face Mike! rofl :-P